tractorpoint.com - The leader in Tractors from Compacts, to Utility, to Full Size Tractors! Kubota, John Deere, New Holland, Kioti, Case/IH, and Others. Keywords=Compact Tractor, Kubota Tractors,  Kioti Tractors, JD, John Deere Tractors, New Holland, Case Boomer, Used Tractors, Classifieds, Dealer Directory, Tractor Pictures / Images
  parts   |   discussion   |   photos   |   podcast   |   reviews   |   specs   |   dealers   |   classifieds   |   contact   |   faq   |   myProfile   |   home          Login Now | Sign Up


Forums > Active Threads > Popular Compact Tractors > Kubota Tractors

Post Message Kubota Tractors


 Go Bottom
____________________________________________________________________________________
Kuboat M9540 Front Loader fluid change problem

View my Photos
psbhouston
Join Date: Dec 2010
Posts: 3 Texas
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster

2010-12-05          175548


I could use some help trying to figure out what is up with the loader on this tractor. It is a Kubota M9540 series with the hydrostatic transmission and a Kubota Front End Loader.

After changing the fluid recently (did not use Kubota fluid- a Cheveron Product compatible to UDT) - the lift function of the loader will not work unless you rev the engine and pump speed. If you use the bucket roll function it works and it will lift fine if you roll back the bucket until it bottom out and then you pull back on the up lever all seems to work very fast.

In other words - when you pull straight back on the arm to lift the bucket it does not want to lift. Is it possible that the fluid is the problem? The shuttle transmission works well and the rear lifts great. Never had a hint of trouble until it just died. Any trouble shooting ideas?

I cant remember how long it worked after the fluid change but it started failing very soon after it and within 10 hours of use.

Thanks for you help.

Reply to | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo


____________________________________________________________________________________
Kuboat M9540 Front Loader fluid change problem

View my Photos
candoarms
Join Date: Mar 2007
Posts: 1932 North Dakota
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster  View my Photos  Pics

2010-12-05          175549


Psbhouston,

I'd try disconnecting all of your loader hoses and then checking to see if there isn't something preventing them from seating completely in the quick-disconnects.

From your explanation of the problem, I'm certain that your hydraulic pumps are working just fine.

You have something that is limiting the flow of fluid in the loader lift circuit. Could be a restriction.....ice (In Texas??)...or possibly just a faulty hose connection problem at the loader valve.


Joel ....

Reply to | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo


____________________________________________________________________________________
Kuboat M9540 Front Loader fluid change problem

View my Photos
psbhouston
Join Date: Dec 2010
Posts: 3 Texas
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster

2010-12-05          175551


Thanks for the advice.

Is there a filter screen in the system as well - or do the 2 spin on filters protect it all? ....

Reply to | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo


____________________________________________________________________________________
Kuboat M9540 Front Loader fluid change problem

View my Photos
Art White
Join Date: Jan 2000
Posts: 6898 Waterville New York
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster  View my Photos  Pics

2010-12-06          175552



You may have a hydraulic shuttle but not a hydrostatic transmission.

I feel that your problem as brought up in an earlier post is with your hydraulic disconnects for the loader.

Your problem is only with one component of the hydraulic system not everything!

To open the dump valve and allow the other side or lift to bleed through to get the loader operate poorly is the
tell tale!!!

Change the female ends for lift circuit and you should be fine. Sometimes they just don't seat right and to reinstall them might have things working right again. ....

Reply to | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo


____________________________________________________________________________________
Kuboat M9540 Front Loader fluid change problem

View my Photos
kthompson
Join Date: Oct 2005
Posts: 5242 South Carolina
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster  View my Photos  Pics

2010-12-06          175560


Art is the pro but you did use Kubota filters, correct? ....

Reply to | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo



Return to index    Go Top


Share This