tractorpoint.com - The leader in Tractors from Compacts, to Utility, to Full Size Tractors! Kubota, John Deere, New Holland, Kioti, Case/IH, and Others. Keywords=Compact Tractor, Kubota Tractors,  Kioti Tractors, JD, John Deere Tractors, New Holland, Case Boomer, Used Tractors, Classifieds, Dealer Directory, Tractor Pictures / Images
  parts   |   discussion   |   photos   |   podcast   |   reviews   |   specs   |   dealers   |   classifieds   |   contact   |   faq   |   myProfile   |   home          Login Now | Sign Up

Forums > Active Threads > Other Tractor Brands > Jinma Farmpro Agracat Nortrac

Post Message Jinma Farmpro Agracat Nortrac

 Go Bottom
____________________________________________________________________________________
Jinma tractor king 200

View my Photos
kubota1600
Join Date: Dec 2015
Posts: 2
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster

2015-12-07          194167


Working on this for a family member... Gauges have never worked on this tractor so I have replaced all relays and fuses, checked every connection cleaned and reconnected and still nothing. The gauges will light up and all lights, blinkers, and horn still work but, theirs no oil pressure, temp,or rpm readings and the hour meter says error. Im at a loss the only thing i've found is a ground that is not hooked up so, i scuffed off the paint stuck it on the frame and it got me no where lol.
Any help would be greatly appreciated!

Reply to | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo


____________________________________________________________________________________
Jinma tractor king 200

View my Photos
kthompson
Join Date: Oct 2005
Posts: 5219 South Carolina
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster  View my Photos  Pics

2015-12-10          194180


Saying they never worked..since new or new to them meaning did they get it used?

Hard to believe four sending units would all be bad but possible. I would try to test with volt meter and see if you can detect any voltage change on oil pressure sending unit from not running to idling. If none then think sending unit is bad. Again hard to believe all four sending units are bad unless there was a voltage spike to the system.

Is there a connection where all the wires are in a single plug and by change it is not plugged in correctly, like it is roated 180 degrees throwing all circuits off? ....

Reply to | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo



Return to index    Go Top


Share This



Tractorpoint Parts
Fast Delivery!
Low Prices
Tractor Cab Glass for sale
Cab Glass