1070 fuel and temp gauge not working: John Deere Review  -- John Deere Tractors Discussion Forum and Review 1070 fuel and temp gauge not working: John Deere Review -- John Deere Tractors Discussion Forum

  parts   |   manuals   |   discussion   |   photos   |   podcast   |   reviews   |   specs   |   dealers   |   classifieds   |   contact   |   faq   |   myProfile   |   home          Login Now | Sign Up


FAQ:   What is a tractor?

Forum Index
New As Posted | Active Subjects



www.emerichsales.com - New & Used Equipment
          View Tractors For Sale!


www.partsbynet.com - Lawn and Garden Equipment Parts


Bernardsville Landscape Lighting
Click to Post a New Message!

Discussion Boards > Active Subjects > Messages as Posted > John Deere Review Forum

Page [ 1 ] |
Reply | Pop Up Window Reply | Add PhotoAdd Photo
 05-31-2005, 10:52 Post: 111758
k9fletch



View my Photos

View my Photos  Pics
Join Date: Jul 2003
Location: Whittemore, MI
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster
Posts: 52

2
Filter by User
 1070 fuel and temp gauge not working

My fuel and temp gauge are not working, they were reading before. I can see fuel in the tank (topped off) and I have good coolant levels. Upon starting the tractor I get a slight jump in the fuel gauge but it is still reading well below empty as is the temp gauge. This is a new tractor to me but it has about 900hrs on the tach. I can't find the fuse panel either. Any suggestions?






Reply to PostReply | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo




Bookmarks: Digg It | Del.icio.us | Stumble This

 05-31-2005, 11:01 Post: 111759
k9fletch



View my Photos

View my Photos  Pics
Join Date: Jul 2003
Location: Whittemore, MI
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster
Posts: 52

2
Filter by User
 1070 fuel and temp gauge not working

Update: I just ran the tractor for about 10 minutes and the fuel gauge did come up to a full reading but the temp gauge is still burried reading below the cold side, is this normal? I think I should get some movement on the temp guage upon start up?






Reply to PostReply | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo




Bookmarks: Digg It | Del.icio.us | Stumble This

 06-01-2005, 09:43 Post: 111802
Chief



View my Photos

View my Photos  Pics
Join Date: Jul 2003
Location: Southwest MiddleTennessee
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster
Posts: 4278
 1070 fuel and temp gauge not working

It could be any of a number of things causing this. I would suggest double checking all wire connections and grounds 1st. Then it is most likely narrowed down to the sending unit or gauge. Being that is sounds like this just recently happened and both gauges at the same time; I would think a faulty or corroded wire connection or fuse could be the culprit.






Reply to PostReply | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo




Bookmarks: Digg It | Del.icio.us | Stumble This

 06-06-2005, 13:32 Post: 111990
yaffer



Join Date: Jul 2003
Location: Brookshire, TX
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster
Posts: 5
 1070 fuel and temp gauge not working

There was a thread concerning this problem several years ago regarding 870 series tractors. I had the problem on my 870 and ended up replacing the instrument cluster. It was about $120 at the time. I think moisture gets into cluster and increases friction on the gauge movements. Mine would try to come off zero when my problem first started and sometimes they would move upscale normally and sometimes they stayed stuck. You could see them try to move when you started engine so I was pretty sure I was dealing with a mechanical issue.






Reply to PostReply | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo




Bookmarks: Digg It | Del.icio.us | Stumble This

Reply | Pop Up Window Reply | Add PhotoAdd Photo


Page [ 1 ] |

Discussion Boards > Active Subjects > Messages as Posted > John Deere Review Forum

Thread 111758 Filter by Poster:
Chief 1 | k9fletch 2 | yaffer 1 |




Most Viewed

+ John Deere 2210 Backhoe Review
+ John Deere vs Kubota Compact Tractors
+ John Deere 790 fuel shut-off solenoid failing???
+ John Deere low viscosity HY GARD
+ John Deere JD 4100 Wiring diagram
+ JD 790 or Kubota L3000DT
+ Should I buy a John Deere 4105???
+ John Deere 4300 turns over but won't start
+ John Deere 455 garden tractor
+ Oil Change for Diesel Tractor

Most Discussion

+ John Deere 4300 scuffing......
+ Possible Solution To The 4000
+ Dealer out to lunch
+ Just got my new JD 4410 - Prob
+ Hello Green, Goodbye Orange
+ Receiver hitch for iMatch
+ 4300 wheel bolt problems
+ 4000 Ten Series 50 hour break
+ Don't buy JD compact tractors.
+ Oil Change for Diesel Tractor

Newest Topics

+ Oil overflow from tube and Smoke
+ John Deere 4100 gear 3 point not workin
+ 2000 John Deer Gator 4 X2
+ Mini Excavator SY20C - Small Body with Big Power
+ John Deer 1070 starting problem
+ John Deere 990
+ Tractors R Us
+ john deere 4100 with 410 loader hydraulic problem
+ John Deere 2032R Buying advice
+ John Deere 2010 loss of hydraulics













Turbochargers for Tractors and Industrial Machines
Cab Glass for Tractors and Industrial Machines

Alternators for Tractors and Industrial Machines
Radiators for Tractors and Industrial Machines

Driveline Components for Tractors and Industrial Machines
Starter Motors for Tractors and Industrial Machines