Y485 Fuel flooding my Fuel Injection Pump: Chinese Tractors -- Jinma Farmpro Agracat  -- Chinese Tractors Discussion Forum and Review Y485 Fuel flooding my Fuel Injection Pump: Chinese Tractors -- Jinma Farmpro Agracat -- Chinese Tractors Discussion Forum

  parts   |   manuals   |   discussion   |   photos   |   podcast   |   reviews   |   specs   |   dealers   |   classifieds   |   contact   |   faq   |   myProfile   |   home          Login Now | Sign Up


FAQ:   What is a tractor?

Forum Index
New As Posted | Active Subjects



www.emerichsales.com - New & Used Equipment
          View Tractors For Sale!


www.partsbynet.com - Lawn and Garden Equipment Parts


Bernardsville Landscape Lighting
Click to Post a New Message!

Discussion Boards > Active Subjects > Messages as Posted > Chinese Tractors -- Jinma Farmpro Agracat Forum

Page [ 1 ] | 2 | | Next >>
Reply | Pop Up Window Reply | Add PhotoAdd Photo
 08-10-2014, 18:21 Post: 190884
stevek924



Join Date: Aug 2014
Location: West Virginia
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster
Posts: 17

8
Filter by User
 Y485 Fuel flooding my Fuel Injection Pump

I donít have a Chinese tractor but I am in possession of a Yangdong Y485 engine (as best I can figure that is, the one & only data plate is in Chinese) and am in need of some troubleshooting assistance. I am a true novice concerning diesel engines in general and Chinese diesels in particular. There seems to be a lot of knowledge in this forum.
Long story short Ė bought a generator powered by the aforementioned Y485. The previous owner had a problem with the solenoid that holds the shutoff lever in the run position and somehow ended up pulling the rear cover off the fuel injection pump governor section (Iím sure thereís a long story in there also). Thatís where his troubleshooting stopped.

I fixed the solenoid problem (bad wire), located and installed a new fuel pump since I had no idea what piece parts may have been lost from the one that was there, changed the oil and coolant, rebuilt the water pump, and today cranked it up for the first time.
This is where my problem starts; I used the priming pump and got fuel out of the forward bleed port just below the output line fittings. I gave it a few more pumps with the bleed port closed off and got fuel out of the banjo fitting that the injector return line attaches to on the aft side of the output manifold block. In hindsight this may not have been a good sign.
I cranked it over about three times, for about 10 to 15 seconds each time, it did not start. What it did do was start dripping (spewing is probably a better term) fuel out of the overflow tube for the lube oil in the pump. It was also dripping fuel from the bottom of the mating surface of the two halves of the governor housing.
I pulled the oil drain plug from the pump and got about 1/3 to 1/2 a cup of a fuel/oil mixture. Replenished the oil in the pump, just to the lower line on the dipstick, and cranked it two more times. Again, both times for about 10 seconds each and again, no light off. Checked the oil level in the pump and it was up the top line at the top of the little dipstick. Again, a mixture of fuel and oil.
One last time I drained and refilled the oil in the pump and this time when I cranked it I loosened the fuel lines at the injectors. Got absolutely no fuel at the injectors but did fill up the pump body again.

Now for some background, the pump I bought had some differences from the one I took off. Internal min/max speed adjustments on the new one as opposed to external, different vent on the governor section, the fuel shut off arm was 180 out (pointed outboard on the new one as opposed to pointing inboard on the original), and the boss that houses the shaft seal on the mating flange of the new one was about 2Ē in diameter as opposed to about 1Ē on the original.
I donít see the vent & adjustments as much to worry about. The shut off arm problem was solved by repositioning the solenoid. Fortunately for me the previous owner had replaced the solenoid with the wrong type. He installed a pull solenoid instead of a push which was the original configuration. The biggest opportunity I see for my screwing something up was having to swap the pump mounting flange from the old one to the new one to get it to mate with the engine. That went pretty smooth, everything lined up perfectly and I didnít have to force anything into positon.

Iím at a loss. No output to the injectors is a big problem but not as big as the internal leakage.
Could I have ruptured an internal diaphragm, or blown out an internal seal with the priming pump? I do have the old pump that I would try and use as a donor if there is something I could try to resolve the issue. Returning the purchased pump is not an option, if it comes to that Iím looking a buying another one.

Can anyone out there offer some advice?






Reply to PostReply | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo




Bookmarks: Digg It | Del.icio.us | Technorati | Furl | Stumble This

 08-11-2014, 16:49 Post: 190897
minimac



View my Photos

View my Photos  Pics
Join Date: Jun 2013
Location:
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster
Posts: 39
 Y485 Fuel flooding my Fuel Injection Pump

Wow ... you have so much going on there all at once, that is a tough one. Can you add some pictures?






Reply to PostReply | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo




Bookmarks: Digg It | Del.icio.us | Technorati | Furl | Stumble This

 08-11-2014, 21:16 Post: 190898
stevek924



Join Date: Aug 2014
Location: West Virginia
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster
Posts: 17

8
Filter by User
 Y485 Fuel flooding my Fuel Injection Pump

Thanks for the response Minimac. It'll be Saturday before I can get some pictures but I'll post them as soon as I can. Anything in particular you want to see?






Reply to PostReply | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo




Bookmarks: Digg It | Del.icio.us | Technorati | Furl | Stumble This

 08-16-2014, 21:05 Post: 190924
stevek924



Join Date: Aug 2014
Location: West Virginia
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster
Posts: 17

8
Filter by User
 Y485 Fuel flooding my Fuel Injection Pump

Pictures.
One side shot of the engine/generator and a second one showing where I'm getting the fuel leaking out when it fills up the body of the pump.
The curved tube (circled, forward) dumps excess oil from the pump body overboard. In my case it dumps the fuel/oil mix.
Was also leaking from the governor section mating flange just aft of the drain plug (circled, aft).






Reply to PostReply | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo




Bookmarks: Digg It | Del.icio.us | Technorati | Furl | Stumble This

 08-16-2014, 22:07 Post: 190925
stevek924



Join Date: Aug 2014
Location: West Virginia
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster
Posts: 17

8
Filter by User
 Y485 Fuel flooding my Fuel Injection Pump





Picture Link
Chinese Tractors -- Jinma Farmpro Agracat: Y485-Fuel-flooding-my-Fuel-Injection-Pump

Reply to PostReply | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo




Bookmarks: Digg It | Del.icio.us | Technorati | Furl | Stumble This

 08-16-2014, 22:09 Post: 190926
stevek924



Join Date: Aug 2014
Location: West Virginia
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster
Posts: 17

8
Filter by User
 Y485 Fuel flooding my Fuel Injection Pump





Picture Link
Chinese Tractors -- Jinma Farmpro Agracat: Y485-Fuel-flooding-my-Fuel-Injection-Pump

Reply to PostReply | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo




Bookmarks: Digg It | Del.icio.us | Technorati | Furl | Stumble This

 08-22-2014, 14:45 Post: 190975
DennisCTB

TP Contributor

View my Photos

View my Photos  Pics
Join Date: Nov 1998
Location: NorthWest NJ
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster
Posts: 2544

2
Filter by User
 Y485 Fuel flooding my Fuel Injection Pump

Bump! Anyone have an idea on this?






Reply to PostReply | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo




Bookmarks: Digg It | Del.icio.us | Technorati | Furl | Stumble This

 08-25-2014, 07:53 Post: 190995
stevek924



Join Date: Aug 2014
Location: West Virginia
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster
Posts: 17

8
Filter by User
 Y485 Fuel flooding my Fuel Injection Pump

Swapped out the priming pump form the old unit. Other than an internal leak that was the only point I could figure where fuel could transfer to the pump body.

No joy, still filling the pump body with fuel after about 20 seconds of cranking.






Reply to PostReply | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo




Bookmarks: Digg It | Del.icio.us | Technorati | Furl | Stumble This

 09-19-2014, 10:30 Post: 191092
stevek924



Join Date: Aug 2014
Location: West Virginia
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster
Posts: 17

8
Filter by User
 Y485 Fuel flooding my Fuel Injection Pump

Made one good pump out of two bad ones, have the original unit installed. No more flooding the pump body with fuel.
Cleaned the injectors and now have fuel to the cylinders but no light off.
Next step - adjust the timing. Other projects on the front burner but this is high on the list. Will post progress in case anyone is interested.






Reply to PostReply | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo




Bookmarks: Digg It | Del.icio.us | Technorati | Furl | Stumble This

 09-19-2014, 13:00 Post: 191093
DennisCTB

TP Contributor

View my Photos

View my Photos  Pics
Join Date: Nov 1998
Location: NorthWest NJ
TractorPoint Premium Member -- 5 Tractors = Very Frequent Poster
Posts: 2544

2
Filter by User
 Y485 Fuel flooding my Fuel Injection Pump

Hey glad you are making progress keep us posted






Reply to PostReply | Quote Post Reply to PostQuote Reply | Add PhotoAdd Photo




Bookmarks: Digg It | Del.icio.us | Technorati | Furl | Stumble This

Reply | Pop Up Window Reply | Add PhotoAdd Photo


Page [ 1 ] | 2 | | Next >>

Discussion Boards > Active Subjects > Messages as Posted > Chinese Tractors -- Jinma Farmpro Agracat Forum

Thread 190884 Filter by Poster:
DennisCTB 2 | greg_g 1 | minimac 1 | stevek924 8 |




Most Viewed

+ Jinma Tractors Are They Worth It???
+ Jinma 284 Ammeter 30 Amp fuse keeps blowing
+ JAPANESE or CHINESE
+ Rebuild Yang Dong Y385 Tractor Engine Settings Man
+ Anyone use a Jinma chipper?
+ Jinma 224 Loader does not lift or tilt
+ Farm Pro 2420 won't start
+ Farm Pro 2425 4WD working?
+ Jinma 200 LE tractor dies will not start
+ SHould i buy a JInma

Most Discussion

+ New Chinese Tractors Board
+ Clutch for 354 Jinma
+ Jinma 200 LE tractor dies will
+ Jinma 284 Ammeter 30 Amp fuse
+ JAPANESE or CHINESE
+ Farm Pro 2420 won't start
+ Agracat Tractor
+ Jinma clutch does not disengag
+ Jinma Tractors Are They Worth
+ backblading snow

Newest Topics

+ jinma 284 has no power to anything
+ jinma 284 has no power to anything
+ Nortrac 254 will not start
+ Nortrac 254 will not start
+ fan and cooling
+ Jinma 254 Hydraulics foaming
+ farm pro support
+ Farmpro 2425 PTO slipping
+ Farmpro 2425 PTO slipping
+ Nortrac 254 won t Start













Turbochargers for Tractors and Industrial Machines
Cab Glass for Tractors and Industrial Machines

Alternators for Tractors and Industrial Machines
Radiators for Tractors and Industrial Machines

Driveline Components for Tractors and Industrial Machines
Starter Motors for Tractors and Industrial Machines